Trotz Herbst: Bunte Twitter-Blätter sprengen Blogpost

Trotz Herbst: Bunte Twitter-Blätter sprengen Blogpost

Mein Gott, jetzt hat sie’s. Der berühmte Stoßseufzer aus „My fair Lady“ ist förmlich aus mir herausgebrochen, nachdem ich zwei Tage lang auf einem WordPress-Problem herumgekaut habe, ohne der Lösung auch nur einen Schritt näher zu kommen. Und dann plötzlich die Eingebung, einfach so aus dem Nichts. Bunte Herbstblätter sind schuld, dass ich keine Tweets mehr in einem Blogpost unterbringen konnte.

Ich wollte meine Twitter-Galerie der vergangenen Wochen zeigen. Bilder, die ich bei Twitter gefunden habe und die mich zum Lachen gebracht oder die mir gefallen haben. In bekannter Manier habe ich sie in den WordPress-Beitrag eingebettet. Dann auf  Speichern gedrückt und – nichts. Immer brach der Text innerhalb des ersten eingebetteten Tweets ab, ohne alle notwendigen Befehle, der Rest war und blieb verschwunden. X-mal probiert, immer dasselbe Ergebnis. Es war zum Verzweifeln. Selbst googeln brachte keine Lösung.

Wenn etwas nicht geht, nimmt man halt einen Umweg. Also habe ich im schon lange brach liegenden Blogdesk-Blogeditor noch einmal den Blogpost vorbereitet, weil ich dachte, ich kann ihn so samt eingebetteter Tweets durch die Hintertür hochladen. Denkste. Beim Hochladen gab es jedes Mal eine Fehlermeldung. Diese hier.

 

aTweets1

Ich konnte nicht allzu viel damit anfangen, habe aber herausgelesen, dass es ein Problem mit dem Server gibt. Also habe ich meinen Hoster United Domains angeschrieben mit der Bitte um Aufklärung. Die Antwort hat mir leider nicht weitergeholfen.

Die XML-RPC-Schnittstelle von WordPress akzeptiert nur POST-Anfragen.
Wenn eine GET-Anfrage erfolgt, dann wird die Meldung „XML-RPC server accepts POST requests only“ von WordPress ausgegeben. Ich vermute daher einen Fehler in BlogDesk.“

Na klasse. Ich habe die aktuelle Blogdesk-Version, es hat immer geklappt, und nirgends bei Blogdesk gibt es eine Möglichkeit, eine Post-Anfrage anstelle einer Get-Anfrage einzustellen. Der Weg blieb also versperrt.

Die Lösung des Problems schien in immer weitere Ferne zu rücken. Und so habe ich grummelnd vor dem Rechner gesessen, hin und her probiert, aber das Ergebnis blieb immer gleich. Der erste eingebettete Tweet brach in der Mitte ab, nichts ging. Dieser erste Tweets war dieser hier, einer mit einem schönen Foto und diesen tollen Icons in Form von bunten Blättern im Text.

abunt

Ich weiß nicht warum, aber plötzlich habe ich mir bedacht: probier’s doch mal mit einem anderen Tweet, ohne diesen ersten in der Reihe. Und es funktionierte. Ich vermute, die Befehle für die bunten Blätter im Tweet-Text werden von WordPress nicht akzeptiert oder bringen den Editor zum Kollabieren. Denn genau hinter dem Wort „all“ brach der Blog-Eintrag immer ab. Ohne diesen Tweets klappt es problemlos. Den Twitter-Foto-Blogpost gibt es in Kürze hier zu sehen.

Nicht gelöst habe ich das Blogdesk-Problem. Auch normaler Text lässt sich nicht mehr hochladen, stets kommt die oben gezeigte Fehlermeldung. Aber das macht nichts, ich schreibe sowieso meistens direkt im Blog-Backend. Blogdesk war ja nur der Notnagel, der leider nicht gehalten hat.

Weiß vielleicht doch jemand, wie man bei Blogdesk den Fehler beseitigt?

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

This Blog will give regular Commentators DoFollow Status. Implemented from IT Blögg